There is suppose to be hot water in the water heater, right?

A local contractor installed a new furnace and water heater for me on 1/21/2013.  The install appeared to go well.  The furnace is keeping our house warm and the water heater runs without making crazy noise and it is producing hot water.  All is perfect in the world, well not quite…

While checking out the water heater (AO Smith GDHE-50) I noticed that the lower side connect was quite cold, the brass drain was very cold too.  My three other water heaters never exhibited anything like this when they had hot water in them.  The valve and the side connectors were quite warm when the unit was at standby.

To quantify how much cold water is in the heater I did the following experiment.  Immediately after the unit completed a heating cycle (120F, 8F differential) I turned the water heater off.  I then closed the cold water value to the water heater and opened a hot water faucet to allow air into the system.  Then I systematically drained a gallon of water at a time from the water heater drain and took its temperature with a digital thermometer, repeating until I hit water that was 120F.  My best guess at starting was that there is at least 16 gallons of fairly cold water in the heater as each vertical inch is just under a gallon of water and the side connector is 16″ off the floor.  These are my results:wh

As you can see the water heater had 11 gallons of water < 60F.  The results of this experiment indicate to me that something is wrong.  Past water heaters, I was able to get very hot water instantly out of the drain.

OK, so what’s the problem as long as we have hot water coming out the top?  Bacterial growth in the tank.  See http://www.treehugger.com/green-food/is-it-safe-to-turn-down-your-water-heater-temperature.html

This looks like the ultimate petri dish.